HP-41C malfunction during startup

Everything about 41C 41CV and 41CX Hardware

HP-41C malfunction during startup

Postby prwktokali » Thu Jun 28, 2018 9:22 pm

So i recently found an HP-41C calculator while searching my fathers old stuff. It came with an extra memory module, a magnetic card reader (although i couldn't find any cards) and a small printer with some rolls. All the manuals were completely destroyed by mold, but i managed to find almost everything in pdf form with a quick search.
Since i really like vintage tech stuff i decided to try and make it operational again. After buying batteries (which were quite expensive!) i found out that it wouldn't turn on at all. After opening it up and searching for all the common troubleshooting cases, it became obvious that my fathers calculator suffered from a broken lower screw post. It was an easy fix, just using a longer screw. After inserting batteries the calculator seemed to work just fine. The display was clear and the operations got carried out normally. However after i put it aside and reached for it again after a few hours, it became clear that there were still some issues. When pressing the ON button, the display would light up on random places (mostly on the upper part) for a brief period (half a second or less is my best guess) and then completely die out. After repeatedly pressing ON or other keys such as ALPHA and USER (or removing and placing back the batteries in extreme cases) it would eventually turn on and operate flawlessly. Turning it off and then quickly on again was also fine, but if left off for more than 2-3 minutes it would be again very hard to start up. It always behaves like that and sometimes it also completely locks up and makes weird sounds. I get the general feel that it "struggles" to turn on, but if it does it works perfectly after that. No MEMORY LOST seems to appear in any case. It's also interesting that when i connect any peripheral, it will never turn on no matter what, which makes me believe even more that it has some issue with power supply during startup.
I know that this is a similar problem to others mentioned here or other forums/groups but i think it is important that such problems are described in detail so that anybody searching in the future can be sure that he experiences the same kind of malfunction. Considering these I decided to take the time and post here for help, since this calculator apart from being pretty cool also has sentimental value to my father who was pretty happy to see it running again, at least with that culprit.
I'm really sorry for the long post but i tried to be as detailed as possible. I'd like to thank in advance anyone reading this for the time he invested and hope that you have some info on the problem described above.
prwktokali
.
.
 
Posts: 1
Joined: Thu Jun 28, 2018 9:12 pm

Return to HP-41 Hardware

Who is online

Users browsing this forum: Yandex [Bot] and 1 guest

cron